Стандартная ситуация – вы ведете в табличке продажи по дням. Примерно так:

таблица выравнивание в Excel

Вроде все видно и наглядно, однако очень часто нужно видеть сумму нарастающим итогом для каждой даты
Для этого обычно используется формула которую вы видите в этом примере в окне формул

формулы Excel

Суть ее – берем предыдущую сумму и добавляет продажи за текущий день.
Но есть более грамотный и красивый способ.
В колонке «Сумма нарастающим итогом» пишем формулу =СУММ($D$4:D4)
Важно чтобы верхняя граница суммируемого диапазона не изменялась, именно для этого перед координатами ячейки ставится знак «$», а нижняя наоборот при копировании изменялась так, чтобы при копировании вниз изменялся нужный нам диапазон

формулы Эксель

Вы можете видеть, что при копировании этой формулы на одну строку вниз, верхняя граница суммирования осталась неизменной, а нижняя расширяется в соответствии с выбранной строкой.

Решения Excel

Вы спросите - чем этот способ лучше?
Допустим вам нужна сумма нарастающим итогом не на каждый день а через день или раз в неделю или в пять дней. При первом варианте, если вы удалите сумму нарастающим в каком-то из дней, все ваши вычисления «поплывут» и будут показывать неправильные значения.
Во втором варианте, вы можете оставлять значения нарастающим итогом в тех ячейках, которые вам нужны, например каждую пятницу или каждый четный день. Данные всегда будут отражаться корректно.
Да, насчет пятницы, интересная мысль. Что теперь сидеть с календарем и выбирать эти самые пятницы?
Совершенно не обязательно, вы уже догадались, что и эту задачу легко можно решить с помощью формулы в Excel
Для этого существует функция =ДЕНЬНЕД(). Она как раз подходит для нашего случая.
Создаем такую вот формулу:

=ЕСЛИ(ДЕНЬНЕД(A11)=5;СУММ($D$4:D11);"")

В переводе на обычный язык она говорит следующее: Если день недели в ячейке с датой имеет номер 5 (а это как известно пятница), то тогда нужно показать сумму нарастающим итогом, если же нет, то ничего не показывать. «Ничего» и 0 это разные понятия. Поэтому «Ничего» мы обозначаем двумя кавычками ( "" ). В результате таблица будет выглядеть примерно так:

как в Excel сделать промежуточные итоги

Как видите все получилось довольно аккуратно и информативно.
Надеюсь работа в Excel будет доставлять вам только удовольствие.